T-1 Tech support FAQ

My T-1 doesn’t load in T-1 Config. How do I solve this?

Check that your T-1 is appearing as a midi device in your DAW and is responsive when powered up. If this is the case here are some things you can try to make T-1 Config load:

  • Make sure that you have the latest version of T-1 config installed.

  • Reload the Config tool by pressing “CMD+R”/”CTRL+R” or “View” → “Reload”.

  • Unplug and replug T-1 directly to your computer ( avoiding any usb-hubs).

  • If any other external midi devices are connected, try to disconnect them and then go to 1. and 2. 

  • Try flipping the usb-c connector.

My T-1 keeps failing the firmware update process. Why?

Make sure that you are following these steps before updating:

  • You have the latest version of T-1 config installed.

  • You have connected the T-1 directly to your computer without any usb-hubs.

  • You have removed all MIDI cables from the T-1.

  • You are not sending any MIDI including clock via the usb.

If the process keeps failing see “How do I perform a manual firmware update” to update to the latest version included in the T-1 Config tool.

My T-1 is bricked and unresponsive. How do I fix this?

There are two known reasons for this behavior.

1. T-1 got bricked during a firmware update.  

  • To fix this you can flash the firmware manually. Follow the steps in “How do I perform a manual firmware update?” to do so. 

2. One of your saved banks is corrupt, causing the T-1 to keep crashing upon startup.

  • The fastest way to fix this is to erase all banks and settings. Follow the steps in “How do I erase all banks and settings?” to do so.  

  • The second option is to boot the T-1 in safe mode and find and delete the corrupt bank. Follow the steps in “How do I start the T-1 in safe mode?” to do so. 

How do I perform a manual firmware update?

If your T-1 got bricked during a firmware update you will need to perform a manual firmware upload. Follow the instructions below to perform a manual firmware upload:

  • Run from the menu bar of T-1 Config: “Tools” → “Upload Firmware” → “vX.X.X”. 

  • The script will now upload firmware to your T-1, it takes about 2 minutes.

  • NOTE: If automatic port detection fails, follow the on screen instructions to manually enter the serial port.
    macOS:  It will be called something like “/dev/tty.usbmodemXXXXX"
    Windows: It will be called something like “COMxx”, select the one with baudrate = 115200 or 460800

How do I erase all banks and settings?

One of your saved banks is corrupt, causing the T-1 to crash upon startup. This issue can be fixed by erasing all banks and settings - NOTE this will erase all patterns stored on your unit permanently. This operation can also be used as a factory reset. 

Follow the instructions below to erase all banks and settings:

  • Run from the menu bar of T-1 Config: “Tools” → “erase banks and settings”

  • The script will now erase the file system on your T-1.

  • After the process is completed the T-1 will reformat with the LEDs lit in orange. This can take up to 1 minute before the reformatting is completed.

How do I start the T-1 in safe mode?

One of your saved banks is corrupt, causing the T-1 to crash upon startup. This issue can be fixed by starting your T-1 in safe mode, where banks are not automatically loaded.

Follow the instructions below to boot your T-1 in safe mode:

  • Hold [ CTRL ] while plugging in power to your T-1. You can release the button once the first track button LED is lit in orange.

  • Your T-1 should now boot with an empty bank. If your T-1 doesn’t boot to an empty bank, your firmware is corrupted and you can do a manual firmware upload as described in another topic.

  • When the T-1 is in safe mode, banks can be loaded manually by entering the [ BANKS ] menu. All existing banks should be displayed with a red led. Banks can be manually loaded by holding the corresponding button for 1 second.

  • Try loading all your saved banks one at a time. If loading a bank causes the T-1 to be unresponsive, that bank is corrupt and you should clear that bank to return to normal operation.

If you couldn't find an answer to your issue please reach out to support@torsoelectronics.com